Users Encounter Error Page After 3DS Challenge Completion

Incident Report for DIMOCO

Resolved

The root cause of the technical issue is relevant to specific issuers and ACS providers outside of the DIMOCO systems, it will be escalated separately for high volume BINs or upon request from merchants.
Posted Jun 06, 2025 - 08:22 UTC

Identified

Additional logging solution was deployed earlier this week and it showed that the issue is caused by an incorrect response from particular ACS servers to our system.
In those cases, the ACS does not follow the instructions outlined in the technical specification and it is the reason why customers are seeing an error page.

We are currently in the process of gathering a list of all issuers who are handling this incorrectly and we will get in touch with them about fixing this behavior.
Posted May 16, 2025 - 09:40 UTC

Investigating

After completing the 3DS challenge, users are sometimes encountering a Dimoco error page.
It is suspected that the ACS is redirecting the users back with invalid data, which is causing the error.
This is currently under investigation.
Posted Apr 23, 2025 - 12:15 UTC
This incident affected: DIMOCO Payments (API - Card Payments).